Mandatory Software Upgrade: Download ZEN 2.0.18 Now

This post was originally shared on the ZenCash Blog.

Last updated July 5 2019 – New ZEN software (2.0.18) is available for download today!

All exchanges, mining pools, node operators, and full node wallet users must upgrade to ZEN 2.0.18 prior to block #555555, which will occur around the 23rd of July

ZEN 2.0.18 replaces the current version 2.0.17, which is set to deprecate (no longer run).

The focus of this version is the RPC method ‘getblockfinalityindex’ update. This update informs the user after how many blocks a transaction can be considered safe without the possibility of being reverted. In addition, the update adds a check block at height safety control for orphaned blocks, preventing mistakes in raw transaction creation.

The next software upgrade (2.1.0) will bring the full implementation of Sapling and other features to be announced. The release was postponed due to a known denial of service bug in upstream Sapling.

Please update your ZEN software before the 23rd of July.

The new 2.0.18 version is available at https://github.com/ZencashOfficial/zen/releases/tag/v2.0.18 

Alternatively, the new 2.0.18 version is available through the APT repository, see instructions at https://horizenofficial.atlassian.net/wiki/spaces/ZEN/pages/136872130/Upgrade+zend+daemon+using+apt

UPDATES ON ZEN 2.0.18

  • Update RPC method ‘getblockfinalityindex’
  • Check block at height safety control for orphaned blocks

What happens if you do not upgrade before the 23rd of July?

  • Exchanges and Partners: you will not be able to access your funds until you upgrade to the latest version.
  • Pool operators: ZEND will not work and thus you will not be able to mine ZEN until you upgrade to ZEN 2.0.18.
  • Node operators: ZEND will not work and thus you will not be eligible to earn ZEN until you upgrade to ZEN 2.0.18.
  • Full node wallet users (Swing wallet, Sphere by Horizen): you will not be able to access your funds until you upgrade to the latest wallet version.

The new 2.0.18 version is available at https://github.com/ZencashOfficial/zen/releases/tag/v2.0.18

Alternatively, the new 2.0.18 version is available through the APT repository, see instructions at https://horizenofficial.atlassian.net/wiki/spaces/ZEN/pages/136872130/Upgrade+zend+daemon+using+apt

Please let us know if you have any questions. Thank you for your continued support!

The post Mandatory Software Upgrade: Download ZEN 2.0.18 Now appeared first on Horizen.

To read more from ZenCash follow this link.